No se puede encontrar módulo werconcpl.dll

Tema en 'Windows 7' comenzado por raffweb, 17/5/11.

  1. raffweb

    raffweb Nuevo Miembro Miembro

    Buenas noches a todos los colaboradores.
    Tengo un ordenador con Windows 7 Ultimate, 1 Gb de RAM, disco duro de 320 Gb, placa Asus Barebone Pundit R350 el cual estuvo funcionando bien pero de pronto al encenderlo no tiene conexión a internet.
    Al intentar solucionar el problema de conexión aparece un mensaje de error que dice: "Problema al iniciar werconcpl.dll
    No se puede encotrar el modulo especificado".
    Busqué en internet esa librería y la copié en system32, al querer registrarla como decía las instrucciones no me permite registrarla porque dice que no existe ese archivo (pese a que si está) o que pueden falta módulos que dependen de éste.
    Al reiniciar se solucionó el problema de conexión a internet y estuvo así varios días, pero de pronto aparecieron 2 pantallas azules al intentar conectar a internet, ambos com archivos .sys, uno era del Avast y el otro no lo recuerdo.
    Desde que pasó ésto por más que copio el archivo werconcpl.dll en la carpeta system32 e intento registrarla con regsvr32 no lo consigo, y tampoco puedo conectarme más a internet.
    He leído que no precisamente es el archivo werconcpl.dll que tiene el problema sino otros módulos que invocan a él y ahí el error.
    También he probado a restaurar el sistema pero lamentablemente sólo tengo opción a fechas recientes y no a desde cuando empezó el problema.
    Puede alguien darme una solución a este problema?
    Estaré muy agradecido a todos los mensajes.
    Un saludo cordial a todos ustedes.
    Hasta luego.
     
  2. charlie

    charlie Nuevo Miembro Miembro

    ¿Tienes windows actualizado mediante el win. update?
    Realiza una reparación del sistema con el disco de instalación. Esto no te hará perder tus datos y archivos, y nos dices que sucedió.
    Saludos.-
     
  3. raffweb

    raffweb Nuevo Miembro Miembro

    Buenas noches Charlie, gracias por responder.
    Sí, el windows está actualizado, y no tengo cd de instalación.
     
  4. raffweb

    raffweb Nuevo Miembro Miembro

    Hola, te comento algo adicional, además de no tener cd de instalación, cuando intento restaurar el sistema las fechas que están disponibles son de días recientes que no me solucionaría nada ya que el problema con este archivo werconcpl.dll lo tengo desde mucho antes de las fechas de restauración.
    Todo eso unido a que cuando entro en restarar sistema y selecciono la fecha más antigua, no consigue hacerlo porque me sale un mensaje de que el disco duro tiene un error. El mensaje es el siguiente.
    No se ha realizado la operación porque la estructura del disco tiene un error o es ilegible. Error 0x80070571.
    Todo ésto empezó cuando al encender el ordenador no había conexión a internet y al querer solucionar el problema salía el mensaje que no encuentra el módulo weconcol.dll
    Lo descargué de internet, lo reemplacé funCionó unos días pero luego pasó lo mismo, ahora por más que lo reemplazo ya no se conecta más a internet, todo lo contrario ahora hasta no existe el controlador que antes tenía. He descargado el controlador de la página de asus pero igual, no soluciona el problema.
    Tengo que aclarar algo que no sé si servirá como pista. El ordenador inicialmente vino con el XP Home Edition de fábrica, pero se instaló el Windows Ultimate Edition de 32 bits. Sin embargo todo funcionaba normal, no tenía problemas con los drivers hasta que cuando intenté desinstalar el Eset Nod32 que caducó, desde ese día empezarons los problemas. El Nod 32 sigue en el ordenador y hasta me he fijado que en vez de tener el controlador de red que le corresponde aparece el firewall de nod32 como controlador de red. Lo he desactivado he intentado instalar pero no se desinstala.
    Bueno, espero poder contar con vuestra ayuda.
    Muchas gracias.
    Un saludo.
     
  5. jbex

    jbex El que peca y reza empata Administrador

    Primero de nada descarga el desinstalador de Nod32. Una vez desinstalado Nod 32, veamos si continuan los problemas y si podemos le vamos buscando solución.

    Un saludo
     
  6. raffweb

    raffweb Nuevo Miembro Miembro

    Hola jbex, desinstalé el Nod32 con la herramienta que me dijiste pero el problema contínúa. He descargado los controladores de diferentes páginas incluída la de asus, pero nada. Pasé varios antivirus y nada. Utilicé el comando sfc /scannow para corregir errores, usé el FixWin y tampoco tuve resultado favorable.
     
  7. jbex

    jbex El que peca y reza empata Administrador

    raffweb explicas que no tienes conexión a internet, pero no dices si es moden, router... adsl, etc, si conectas via Wi-FI o por cable...

    No se cuanto software de seguridad tienes instalado, pero mira de desactivarlo todo para ver si alguno de ellos es el causante.

    Elimina la conexión a la red y la vuelves a crear.

    Me dices has corrido el comando sfc /scannow y no te ha solucionado nada, lo cual es extraño.

    Un saludo
     
  8. ArgentSouL

    ArgentSouL Nuevo Miembro Miembro

  9. Pato_py

    Pato_py Miembro Activo Miembro

    Luego de haber desinstalado el Nod con la herramienta que paso Jbex, continúa como controlador de red lo que comentaste mas arriba?

    En este punto deberias de tener el controlador de la tarjteta de red, y no el del nod.

    Podrias fijarte? si aun sigue aca el firewall del Nod presente (cosa que no deberia pasar ya que el desinstalador deberia sacarlo todo), intenta desinstalarlo, y si no se desinstala intenta hacerlo en modo seguro, ahi no estan activas las conexiones de red y deberia de dejartelo. Luego instalas el controlador de red de tu placa.

    Y si en este punto ya tienes el de tu placa y no el del Nod, te pediria que como prueba desinstales el controlador que tienes actual, reinicies y lo vuelvas a instalar.

    Y luego pruebas de nuevo lo de la conexion a internet.

    Cordial saludo.
     

Comparte esta página