Asociar un icono a un tipo de extension

Tema en 'Windows XP' comenzado por virutas13, 24/9/05.

Estado del tema:
No está abierto para más respuestas.
  1. virutas13

    virutas13 Miembro Miembro

    Hola a todos:

    Tengo un problemilla con los iconos que se asocian a cada tipo de extension.

    Antes cada archivo tenia su propio dibujillo, si era de Winamp pues el dibujo era amarillo y tenia como un rayo, si era de Windows media player pues el icono es como un circulo con un triangulo dentro, bueno lo normal.

    Cuando queria cambiar el programa que Windows utilizaria siempre para ejecutar ese fichero (Abrir con...) automáticamente cambiaba el icono asignado a ese tipo de extension de esos ficheros.

    El problema es que los ficheros de musica, me da igual si es .mp3 u otra extension, como los de vídeo .avi .mpeg etc... no hay manera de que aparezca el dibujo del icono simplemente sale el icono que utiliza Windows cuando se tiene un fichero que tiene una extension desconocida o no se tiene asignado ningún programa para que lo ejecute.

    Si yo pincho el cualquiera de esos ficheros se ejecuta correctamente con el programa asignado. Que es lo que tengo que hacer para que se vuelva a ver los iconos, lo he probado todo, o casi todo.

    Muchas gracias. Un saludo.
     
  2. Damien

    Damien Nuevo Miembro Miembro

    Te diriges a:

    Panel de control>Opciones de carpeta>Tipos de archivo

    .....y busca el tipo de archivo que quieres modificar, lo seleccionas y le das click en “Opciones avanzadas".

    Por ejemplo .mp3:

    [​IMG]
     
  3. virutas13

    virutas13 Miembro Miembro

    Ya hice lo que me dices y sigue todo igual.

    Mira esta imagen para que veas como en opciones de carpeta cambia el icono asignado a los ficheros .mp3 pero si observas en los ficheros de detras son .mp3 y no cambian. Lo he probado incluso poniendo otro icono o asignando en ligar del Winamp el reproductor de Windows para ver si se asignaba el icono del reproductor de Windows y me da igual que igual me da, nada de nada.

    [​IMG]

    ¿Alguna idea mas por favor?

    Gracias por contestar.

    Un saludo
     
  4. Damien

    Damien Nuevo Miembro Miembro

    Por lo que veo en tu captura, has FORZADO a que los archivos .mp3 funcionen con una aplicación distinta a la que estaban asignados (destaca el botón restaurar).

    Sigue al pie de la letra (si lo desea por supuesto):

    1.-Dale al botón "Restaurar" que se encuentra en tu captura. Aplicar y cerrar.

    2.-Luego tal cual te dije antes "busca el tipo de archivo que quieres modificar, lo seleccionas y le das click en “Opciones avanzadas"</span> (y es en "Opciones avanzadas" para que los cambios que realices no sean FORZADOS).

    3.-Click en "Cambiar icono". Selecciona uno y aceptas. Si lo deseas puedes darle al botón "Examinar" para buscar iconos en otras ubicaciones.

    Si después de esto tus iconos siguen mal, las razones podrían ser:

    -El "Iconcache" del sistema se encuentra dañado o saturado (improbable).

    -La librería donde Winamp conserva sus iconos esta dañada (no me lo creo).

    -El sistema no enruta correctamente el destino de los iconos asignados a algúnos tipos de archivo (no sabría como solucionarlo).

    PD.-Si pongo "al pie de la letra" es porque aunque veas en tu captura el icono correcto para los archivos .mp3, los más probable es que no este correctamente asignado. Siguiendo los 3 pasos se corregiría ese fallo.
     
  5. virutas13

    virutas13 Miembro Miembro

    Hola,

    "1.-Dale al botón "Restaurar" que se encuentra en tu captura. Aplicar y cerrar"

    Sigo todo al pie de la letra, le doy a Restaurar pero no puedo darle a Aplicar, si que puedo al boton de Cerrar pero no al de Aplicar ..... ¿Por que pasa esto?

    Muchas Gracias.

    Una Saludo.
     
Estado del tema:
No está abierto para más respuestas.

Comparte esta página