Creación de nuestro usuario para MySQL

Estado
Cerrado para nuevas respuestas

Javi47008

Miembro
Miembro
#1
Ya estoy aquí de nuevo con una duda.

Sigo con el manual de http://www.maestrosdelweb.com/editorial/phpmysqlap/#1

Ahora me he quedado en: 5.1 - Creación de nuestro usuario para MySQL

y me dice: "pinchamos en el link Privilegios y en la siguiente pantalla damos a Agregar nuevo usuario"

No me aparece nada que diga privilegios.

solo aparece: Lenguaje, Tema/Estilo, Documentación de phpMyAdmin, Página oficial de phpMyAdmin, [Change log], [CVS] y
  • .

    Cual es?

    Otra cosilla: Desde que tengo ejecutado el Apache cada vez que doy en la barra de tareas para ir a un aplicación o carpeta primero parpadea, si lo doy una segunda vez se minimiza y a la tercera vez se maximiza y puedo usarlo. ¿Esto porqué es? Ahora uso "Alt + Tab" para cambiar de aplicación ya que va directamente.

    Gracias.
 

alnitak

Ex-Admin
Miembro
#2
Tienes que logearte en el PhpMyAdmin con privilegios de root o no podrás ver todas las opciones.

Por defecto se crea el usuario root sin password, al entrar desde este usuario te deberian salir estas opciones:

Mostrar información de marcha de MySQL

Mostrar las variables del sistema MySQL [Documentación]

Mostrar procesos [Documentación]

Reinicio de MySQL [Documentación]

Privilegios

Bases de datos

Exportar

Cambio de contraseña

Salir

Si te has logeado como root y aun así no te salen las opciones de Mysql sino solamente las de phpMyAdmin entonces imagino que no habrás editado correctamente el config.inc.php

$cfg['PmaAbsoluteUri'] = 'http://localhost/phpmyadmin/';

si esa es tu carpeta de instalacion.

La otra pregunta no la he entendido :(
 

Javi47008

Miembro
Miembro
#3
El config.inc.php lo tengo bien editado.

Entonces será lo de logearme en el PhpMyAdmin con privilegios de root.

¿Como lo hago?

No sé si lo he hecho.

Yo sigo el manual que me dijiste al pié de la letra y como dice alguien "Me lo contaron y lo ví, lo hice y lo aprendí".

Por cierto, muchas gracias por todo, eres el único que me hecha una mano.
 

alnitak

Ex-Admin
Miembro
#4
Cuando entres al phpmyadmin te pedirá que eligas el idioma y que introduzcas user y password.

El user es root

el password debes dejarlo en blanco

De esta manera te logearás como usuario root.

Imagino que a la hora de ejecutar el winmysqladmin.exe por primera vez te habrá pedido que introdujeras un user y un password y me imagino que estarás tratando de logearte en el phpmyadmin con esos user y password, probablemente alli esté tu error, debes entrar como root para poder editar los privilegios.

PD:

Si ya entas directo con el password y user que has introducido dale a salir o si no te sale la opción para salir elimina la cookie y vuelve a entrar para logearte ahora como root
 

Javi47008

Miembro
Miembro
#5
Me parece que me hablas en un nivel informático que me desborda.

He salido de apache y de lo del semáforo.

He vuelo a arrancar el Apache y al escribir en el explorador http://localhost/phpmyadmin/index.php me sale lo mismo de antes.

En cuanto a lo de ejecutar el phpmyadmin no encuentro ningún ejecutable.
 

alnitak

Ex-Admin
Miembro
#6
je, a ver si me puedo explicar mejor

Elimina las cookies

Ahora coloca esta url en el navegador:

http://localhost/phpmyadmin/index.php

entrarás a la pantalla de bienvenida del phpmyadmin donde te pedirá que eligas el idioma y que coloques el user y el password.

En el campo user coloca: root

El campo password dejalo en blanco

Ya entrarás al phpmyadmin logeado como usuario "root" y te deberían salir todas las opciones disponibles.

El termino "root" es tomado de Unix, en un sistema operativo Unix el usuario root es el unico con acceso total a todo, hasta a destrozar el sistema operativo mismo, algo así como un administrador de Windows pero con bastante mas poder.

Cuando instalas el mysql esta por defecto crea un usuario cuyo nombre es root y que no tiene password, este usuario es el que debes usar para logearte el en phpmyadmin o no tendrás privilegios para hacer nada.
 

Javi47008

Miembro
Miembro
#7
No, la pantalla de bienvenida es la misma que me salía antes:

Esta:

Imagen Rota/Perdida

Y no sale nada de usuario y password.

Gracias!!!!
 

alnitak

Ex-Admin
Miembro
#8
joder pero que raro, seguro que has borrado las cookies ?

deberia salirte esto:



y después de logear como root debería salir así:



intenta reiniciar el mysql y asegurate de haber borrado las cookies, o mejor aun reinicia todo el sistema pero joder que esto es muy extraño.
 

alnitak

Ex-Admin
Miembro
#9
A ver, explicame algo, como es que tienes instalada la versión 4.0.18 si la ultima creo que es la 4.0.21 ?

No tendrás todavia instalada la que habías instalado antes con el appserv ?

Si es así habria que ver si este crea otro usuario y restringe el usuario root, pero joder que te he pedido que desinstalaras todo lo que tenias del appserv y siguieras los pasos del tutorial :(
 
Estado
Cerrado para nuevas respuestas
Arriba Pie