Dos problemas de Mandriva 2007

Estado
Cerrado para nuevas respuestas

nightnome

Nuevo Miembro
Miembro
#1
Los problemas son los siguinetes:

1º Con el cargador de arranque de Grub no me funciona, cando va a incializarse me da el siguiente error Error 18, en otras versiones de Mandrake en concreto la 10.1 en vez de darme ese error me empezaban a aparecer 69 en la pantalla.

La vredad es que este error no es vital por que Mandriva incluye en Lilo el cual si me va bien, pero en otras distribuciones como debian que el unico que tiene el el Grub fastidia bastante pues me impide utilizarlas.

2º Por otra parte cuando he instalado el Mandriva 2007 con lilio y funciona. Me detecta mi gráfica como ATI X1300/1950XT lo cual esta bien pues mi gráfica es una ATI Radeon X1600 con 512Mb pero el entorno 3D, el Metisse no me funciona cuando me voy a la configuración tiene los dos botones del escritorio 3D inabilitados(ver imagen). ¿Que puedo hacer para solucionarlo?

 
#2
lo del grub, no me acuerdo de la instalación de mandriva (además, al última vez que lo toque aún era mandrake). ¿te da la opción de instalar grub en algúna otra parte? en caso afirmativo instálalo ahí, en caso contrario me dices.

Sobre lo del metisse, comprueba que tengas acelaración gráfica teniendo los drivers de ati instalados(se llaman fglrx)
 

nightnome

Nuevo Miembro
Miembro
#3
¿te da la opción de instalar grub en algúna otra parte?
A que te refieres a mi al final de la instalación me da la opción a elegir entre 3 gestores de arranque: Grub con menu grafico, Grub con menu de texto, Lilo con menu de texto.

Yo elijo cualquiera de los 2 Grubs y se me instalan perfectamente el problema viene cuando se reinicia el equipo y el ordenador inten ta ejecutar el gestor de arranque.

En cuanto a los drivers para instalarlos tengo que ser el super ususario algo que en principio no es problema sino fuera porque el Mandriva no me deja entrar como root, cuando pongo el usuario dice mas o meno: no se puede entrar en modo root, y no es que este mal la clave. He probado a reducir la seguridad a nivel bajo pero sigue igual.

¿sabeis como se elimina este impedimento? en mandrake 10.1 yo podia entrar sin problema como root, pero con mandriva 2007 no.
 
#4
pero al seleccionar grub no tienes ninguna opción para configurarlo?

lo de root es una medida de seguridad, lo que puedes hacer es abrir ua consola y ejecutar su, te pide la contraseña de root, se la das, una vez como root ejecutas urpmi -i fglrx cambiando -i a lo que se use para instalar y fglrx a lo que sea el driver de ati, te he puesto lo que me imagino que sera lo que debas ejecutar) aunque tampoco se si el driver estará en los repositorios, te intentare buscar algñun repositorio que lo tenga ya que el instalador oficial es malo(aunque los drivers en si también dejan bastante que desear)
 

nightnome

Nuevo Miembro
Miembro
#5
pero al seleccionar grub no tienes ninguna opción para configurarlo?
Apenas nada el tiempo y poco mas miralo por ti mismo en la imagenes:





En cuanto al 2º problema me he descargado los drivers de ATI los últimos y lo que traen vienen xon extension .run. Me he mirado un poco la ayuda, y mas o menos he supuesto (se poco ingles) que que se instalan como se muestra en la imagen:



es decir con el comando sh <archivo.run> pero me da un error porque yo tengo la versión X.Org 7.2 luego hago lo que me dice es decir X_VERSION=x710 y me aparece que no tengo permiso he probado ha poner X700 o cualquier otra e igual, aunque yo estoy en la consola como root.¿Que hago mal?
 

nightnome

Nuevo Miembro
Miembro
#7
En primer lugar agradecer las molestias que te estas tomando.

Y en segundo he probado ha instalar este packete que me has dejado en el enlace y me da el siguiente error:



He probando haciendo doble click(muchos rpm se instalan asin) desde Administrador de paquetes(foto) y desde la consola de comandos poniendo urmpi <nombre del paquete>

y en todos me ha dado el mismo error (el que aparece en la caja de error) y no se me instala. Y no solo con el pakete que me has puesto e probado otros drivers de la web principal de ATI que eran mas antiguos y tampoco van, todos me dan el mismo error(el de la imagen).

sobre lo de las opcines, justo debajo de lo de grub o lilo tienes lo de /dev/hda si tienes algún otro disco duro prueba a cambiarlo.
Solo tengo un disco duro y si cambio la particion donde arranca ¿no podría ser peligroso?, también tengo instalado WindowsXP en este disco duro.
 
Estado
Cerrado para nuevas respuestas
Arriba Pie