Duda sobre Access

  • Autor Andoni1985
  • Fecha de inicio
Estado
Cerrado para nuevas respuestas
A

Andoni1985

Guest
#1
Tengo un problema a la hora de realizar listas desplegables.

Tengo una base de datos con una sola tabla y creo un formulario para que salga una lista con los valores de un campo.

Hasta ahí todo bien, pero a la hora de crear el formulario del resultado de la busqueda, tras poner el boton correspodiente y crearlo aparte, al elegir una opción de la lista y darle al boton, me aparece un formulario en blanco.

Si embargo, lo pongo en vista de diseño y todo parece que esta bien, con todos los campos en su itio y todo bien puesto.

Alguien podría aydarme¿?¿?¿

Gracias de antemano
 

PenDriver

Nuevo Miembro
Miembro
#2
Tal vez ya lo hiciste, pero te lo indico por las dudas.

abres el fomulario, en modo diseño

seleccionas el campo donde se supone que está la lista deplegable

clicas boton contrario(o derecho) del mouse

Eliges propiedades

luego aparece una ventana con varias fichas o pestañas, si eliges la pestaña "todas", busca la fila que dice "origen del control", 1 clic

inmediatamente aparecen un combo box, y un cuadradito con 3 puntos en su interior.

si pinchas los 3 puntos se abre el generador de expresiones.

luego puedes elegir la tabla o consulta (query)donde tienes el campo que necesitas

lo pinchas y te genera el nombre del campo en el cuadro superior del generador, aceptas y ya está.

espero que te sirva.
 

foto700

Nuevo Miembro
Miembro
#3
A lo mejor te parece una contestación tonta, pero me pasaba a mí lo mismo en una base de datos de Access, y sólo me ocurría en los formularios cuya tabla estaba vacía (sin datos en las celdas).
 
Estado
Cerrado para nuevas respuestas
Arriba Pie