Importante: Actualizar a eMule 0.48a (Junio. 2007)

Estado
Cerrado para nuevas respuestas

Sonic999

Ex- Mod
Miembro
#1
Edito: Ahora hay que tener la 0.48a. Siempre hay que tener la última versión. Aquí los cambios que tiene la 0.48a:
Insertar CODE, HTML o PHP:
http://forum.emule-project.net/index.php?showtopic=124257
Cambios en 0.47c:

Insertar CODE, HTML o PHP:
http://www.emule-project.net/home/perl/help.cgi?l=17&rm=show_topic&topic_id=852
Ahí está la explicación de la nueva característica que implementa eMule 0.47c, y el porqué de que todos deben actualizarse a esta nueva versión.

Básicamente camufla la información que envías y recibes a través de eMule, con lo cual se incrementa tu protección.

Se recomienda en especial para la gente que sabe que sus proveedores de internet están haciendo cosas raras para evitar el tráfico de información de programas p2p (traffic shapping, bloqueo de puertos, etc.).

Viene desactivada, pero se activa con una casillita en Preferencias--->Seguridad. Sólo activar la 1ra de las 3 casillas que hay.

Yo ya la tengo funcionando hace un tiempo, y veo que funciona tan bien como cualquier otro eMule, así que pueden actualizarse sin problemas.

Y aviso por las dudas, que quienes usen el asistente de configuración y después vean que al conectar al servidor o a Kad les da ID Baja, es porque eMule asignó puertos aleatorios tanto para TCP como UDP... así que tendrán que cambiarlos en preferencias-conexión, o si no, abrirlos en el firewall y/o router.

Saludos.

@Sonic999
 

Sonic999

Ex- Mod
Miembro
#3
La opción te la da cuando inicia (te dice si hay o no una versión nueva), pero hay gente que piensa que por quedarse con la versión antigua le seguirá yendo bien (piensan que cambiarse a la nueva les podrá ir peor - eso es un mito, nada tiene de cierto -).

Ya incluso hay servidores que requieren que tengas la versión 0.47c, como ser los DonkeyServ 1, 2 y 3.

Saludos.

@Sonic999
 

javier_otaru

Nuevo Miembro
Miembro
#4
Haber Sonic999 si entiendo:

Tengo el eMule 0.47a y debo por mi bien (ya que estoy conectado a los DonkeyServ) cambiarme al 0.47c... ok eso entiendo.

Pero ¿Que hago?.

Digo ¿Como lo hago?

1* Desinstalo primero el que tengo y luego instalo el 0.47c?.

2* Desinstalo primero el que tengo y instalo primero el 0.47b, "repito el paso anterior" y recién instalo el 0.47c?.

3* Teniendo instalado el 0.47a, sobre instalo el 0.47c? o primero lo sobre instalo con el 0.47b y luego el 0.47c?.

Ante todo "debo cerrar el Emule antes de hacer cualquier operación"?.

Saludos...

Javier-Argentina
 

Damien

Nuevo Miembro
Miembro
#5
javier_otaru dijo:
Tengo el eMule 0.47a y debo por mi bien (ya que estoy conectado a los DonkeyServ) cambiarme al 0.47c... ok eso entiendo.

Pero ¿Que hago?.

Digo ¿Como lo hago?
¿Qué influencia tiene el sistema operativo que tenga instalado?
eMule corre en todas las versiones de Windows posteriores a W95. Una aplicación P2P utiliza muchas conexiones de red, lo cual implica que el sistema debe tener una implementación estable de los servicios de red. Windows 98 y ME tienen una pobre implementación de los mencionados servicios, empobreciendo el rendimiento de eMule.
Sistemas operativos más recientes como Windows 2000, XP o Vista están mejor equipados para trabajar en red. No utilice los parches del registro de Windows 98 que le prometen incrementar las conexiones posibles. No funcionan correctamente y pueden causar inestabilidad en su sistema.
Arriba
Mensaje de error oleacc.dll no encontrada.
Este mensaje de error puede aparecer al iniciar el eMule en una máquina con Windows 98. La dll no encontrada está en una actualización de sistema de Windows 98 de Microsoft.
Arriba
Mensaje de error unicows.dll no encontrada.
Este mensaje de error puede aparecer al iniciar el eMule en una máquina con Windows 95/98/ME. La dll no encontrada está en Microsoft Layer for Unicode on Windows 95/98/ME Systems (MSLU) versión 1.0. Descarga ese archivo, ejecútalo y cuando te pida la carpeta de destino elige el directorio emule.
Arriba
¿Instalador o binarios?
La versión con instalador está indicada para una instalación limpia del eMule, puesto que contiene todos los archivos y la documentación necesaria. Ejecútelo y el instalador le guiará el resto del proceso.
La distribución de la versión de los binarios se realiza en un solo archivo. El contenido debe ser extraído en el directorio deseado. Es lo indicado a la hora de actualizar la versión del eMule.
Arriba
¿Cómo puedo mantener mis preferencias/descargas cuando actualizo a una nueva versión del eMule?
Extraiga o instale una nueva versión del eMule en el mismo directorio en el que estaba instalada la versión antigua. Sólo eMule.exe y algúnos archivos inherentes al mismo (no contienen datos de usuario) serán reemplazados. Todas las preferencias, así como las descargas se mantendrán. ¡ Se debe cerrar el eMule antes de actualizar a una versión nueva! Una vez instalado el nuevo eMule, para mantener las preferencias existentes, simplemente pulse cancelar cuando aparezca el asistente al iniciar eMule.
Arriba
Actualizando desde eDonkey/Overnet a eMule manteniendo las descargas.
Las versiones de eDonkey anteriores a la .47 utilizan un sistema de partes compatible con el eMule, sin embargo las posteriores a la .47 dividen las descargas temporales en muchos archivos individuales. Para las versiones antiguas de eDonkey, simplemente indique en preferencias como directorio temporal el mismo que utilizaba eDonkey, o mueva los archivos .met y .part del directorio temporal del eDonkey al directorio temporal que utilice eMule. Para hacer esto, eMule tiene que estar apagado. Las nuevas versiones de eDonkey/Overnet, utilizan el sistema de división del archivo de partes. Una opción de "viejo estilo" está disponible en esos clientes, que hace que las descargas temporales se almacenen en un solo archivo. El archivo part.met todavía sigue estando en un formato nuevo e incompatible. eMule v0.30c introdujo una función de conversión para importar descargas de otros programas a sus descargas de eMule. Esta función importa tanto el formato clásico (eMule, eDonkey <=.47) como el formato dividido como el formato "viejo estilo" de clientes eDonkey/Overnet >.47. Los formatos no-eMule (eDonkey/Overnet/Shareaza) serán convertidos al formato eMule. Puede acceder a la función para importar tanto desde la combinación de teclas rápidas (Alt+X) como desde el icono de Herramientas. Todo lo que tiene que hacer aquí es especificar una carpeta que contenga los archivos de partes (.part). eMule intentará convertir automáticamente los archivos de partes y los añadirá en tiempo de ejecución a sus descargas.

¿Instalador o binarios?

La versión con instalador está indicada para una instalación limpia del eMule, puesto que contiene todos los archivos y la documentación necesaria. Ejecútelo y el instalador le guiará el resto del proceso.

La distribución de la versión de los binarios se realiza en un solo archivo. El contenido debe ser extraído en el directorio deseado. Es lo indicado a la hora de actualizar la versión del eMule.

¿Cómo puedo mantener mis preferencias/descargas cuando actualizo a una nueva versión del eMule?

Extraiga o instale una nueva versión del eMule en el mismo directorio en el que estaba instalada la versión antigua. Sólo eMule.exe y algúnos archivos inherentes al mismo (no contienen datos de usuario) serán reemplazados. Todas las preferencias, así como las descargas se mantendrán. ¡ Se debe cerrar el eMule antes de actualizar a una versión nueva! Una vez instalado el nuevo eMule, para mantener las preferencias existentes, simplemente pulse cancelar cuando aparezca el asistente al iniciar eMule.
Módulo de acceso a fragmentos de archivo en eMule v0.5.1 para VideoLAN v1.0.5

El objetivo de este módulo de acceso es posibilitar que VideoLAN (VLC v1.0.5 ) "lea" sin problemas ni interrupciones un archivo .part fragmentado, y por ende incompleto, de eMule. Este módulo de acceso se halla también disponible para versiones anteriores de VLC en la página del proyecto en SourceForge.

Debido a que un archivo part de eMule no contiene normalmente una cadena de
video completa, VLC tiene que examinar el archivo completo para encontrar
todos los datos realmente disponibles. El proceso de examen puede llevar un
tiempo bastante largo, dependiendo de los datos realmente disponibles y del
tamaño del archivo.

Este módulo de acceso evaluará el archivo part.met del correspondiente part de eMule para determinar que datos hay disponibles. Con esta información, el módulo de acceso es capaz de crear un stream virtual sin ningún hueco y
alimentar con este stream a VLC, y así VLC no tendrá ya que examinar el archivo entero, pues solo "verá" los datos realmente disponibles.



Hay más información disponible en archivo Readme (en la descarga) y en la documentación.*
Descargar el módulo extra (Plugin)*
Descargar el código fuente del módulo extra (plugin)*

eMule Shell Extension v 1.1.0 v1.1.0*

Esta extensión del intérprete de comandos permite que el Explorador de Windows
muestre información adicional de los archivos de eMule .part y .part.met que,
de otra forma, solo son visibles desde el propio eMule. La información se
muestra en los globos amarillos (tooltips), la barra inferior de la ventana
(la barra de estado), en la vista "Detalles", entre otros. (Ver imagen adjunta).*

 

Sonic999

Ex- Mod
Miembro
#6
Por supuesto, hay que cerrar emule para actualizar. Y tú puedes tener todos los emules que quieras, no hace falta "desinstalar".

Puedes tener la versión 0.47a, la b, y la c... mientras las tengas en carpetas separadas. Esto sirve por ej. para probar "mods" de eMule que se publican en el foro oficial de emule-project.net. Entonces pruebas los mods y te fijas qué opciones o agregados te gustan más, o si te quedas con el emule oficial.

Lo único importante es la carpeta Config, que contiene tus ficheros de identificación que conservan tus créditos y los de la gente: cryptkey.dat, preferences.dat, clients.met (estos 3 son los de créditos), known.met, server.met, nodes.dat (de todos estos siempre conviene guardar una copia cuando actualizas de versión).

Y el resto es como dejó ahí expuesto Damien.

Saludos.

@Sonic999
 

javier_otaru

Nuevo Miembro
Miembro
#7
Damien:

Entonses como ya tengo instalado el eMule 0.47a, de la pagina oficial debo vajar el "Binario" y instalarlo derecho nomás?. haciendo antes el backup de la carpeta "config".

Extraigo el binario e instalo en el mismo directorio que ya tengo instalado el eMule 0.47a (previamente cerrado) y listo.

Abro el eMule y sera el nuevo eMule 0.47c y me mantuvo mis preferencias/descargas. y eso de "algúnos archivos inherentes al mismo" estos están dentro del emule.exe.

Por ultimo al abrir omito el cuadro que me aparecio por primera vez cuando instale el eMule 0.47a? a eso t erefieres Damien

Un saludo enorme a uds que me ayudan

Javier-Argentina

P/D: que golazo el de Maxi Rodriguez!!
 

Sonic999

Ex- Mod
Miembro
#8
Tal cual. Y si ves que no te cargó bien el archivo de clientes conocidos (en la pestaña Servidores-Registro), tenés las copias de la carpeta config para intentarlo otra vez y hacerlo en una carpeta nueva... total es lo mismo.

Saludos.

@Sonic999
 

javier_otaru

Nuevo Miembro
Miembro
#9
ok Sonic999:

Pero me olvide de preguntar algo... que pasa con lo que estoy descargando?

Un abrazo a uds.

Javier-Argentina
 

Sonic999

Ex- Mod
Miembro
#10
Si usaste la misma carpeta de antes, las descargas seguirán sin problemas. Si usaste otra carpeta, hay que ir a preferencias, directorios, y ahí pones la ruta hacia la carpeta temp donde tienes los temporales que bajabas. O si no, cortas la carpeta temp antigua y la pegas en la nueva carpeta del nuevo emule. Todo esto y más, está explicado en:

Pasos básicos para que funcione eMule

Se recomienda su lectura.

Saludos.

@Sonic999
 

javier_otaru

Nuevo Miembro
Miembro
#11
Listo ya lo hice!

Te comento los pasos:

1º descomprimí el "binario"

2º copie todo lo que traía dentro y reemplacé a los archivos que estaban instalados en el directorio de mi eMule 0.47a

3º ejecute y se abrio el eMule con la nueva verción 0.47c

Lo hice de esta manera porque observe algo importante:

no se instalaba al ejecutar el eMule que venia en"binario", solo se abría y se podía conectar uno mismo, pero no lo reemplazaba al eMule 0.47a

Ahora bien:

*Antes había actualizado la lista de Servidores (Servidores Buenos), siguiendo los pasos del foro y me dio 83, pero ahora que tengo este nuevo me da 32? y el DonkeyServer nº2 me da caído?

¿Que hago?

*Hice como me recomendaron la copia de toda la carpeta "config"... pero como se/o verifico/o etc. que tengo conservado mis créditos y los de la gente. Digo que debería pasar si no los tengo (no digo en que me variará) sino como se que se mantuvieron (puen el el "binario" también traía una carpeta "config"... o no debo copiar esta carpeta y reemplazar a la original.

Para todo lo que hice mal espero poder revertir mi situación.

Ya de nuevo les doy las gracias a uds. Damien y Sonic999

Saludos

Javier-Argentina
 

Sonic999

Ex- Mod
Miembro
#12
Sabes si conservas los créditos porque te cargará sin problemas el archivo de clientes conocidos... si eso carga bien, quiere decir que tu hash de usuario no ha cambiado, por lo que has conservado tus créditos, la gente te seguirá reconociendo.

DonkeyServ 2 a veces da caído... será que hay mucha gente conectada. La lista de servidores fiables no siempre tiene un número fijo... se van cayendo servidores, por lo que conviene actualizar la lista cada tanto.

Saludos.

@Sonic999
 

javier_otaru

Nuevo Miembro
Miembro
#13
Gracias amigos:

Hice lo que me dijeron y me resulto a la perfección. Además tomare todos sus consejos.

Una cosa, mi eMule el actualizado 0.47c la descarga esta re lenteja.

Antes entre 21 y 47; ahora (con igual configuración) valores entre 0.9 y 7.

Porque será?

Gracias.

Saludos a todos

Javier-Argentina
 

Sonic999

Ex- Mod
Miembro
#14
Ya se respondió aquí: Mi eMule anda pésimo...

Todas las versiones de eMule van igual de bien que las anteriores, salvo que la nueva traiga algún fallo grave que necesite corrección rápida (que salga una nueva versión a corregir el fallo).

Cierro el tema. Toda la ayuda para configurar ya está dada en los hilos fijos.

Saludos. Sonic999
 
Estado
Cerrado para nuevas respuestas
Arriba Pie