Solucionado Pantalla integrada no da señal de vídeo en Ubuntu 13.10

Estado
Cerrado para nuevas respuestas

javier0730

Miembro
Miembro
#1
Buenas tardes.

Nuevamente recurro a ustedes por un nuevo problema que tengo.

He instalado Linux Ubuntu 13.10 a 64 bits en una Laptop acer Aspire V5-472-6818 la cual venia con Windows 8.1.
Lo que hice fue quitarle 150 GB a la partición de Windows y dejarla como espacio no asignado para instalar en ella el Linux, desde el arranque con el instalador el menú inicial aparecía correctamente en pantalla, pero cuando yo elegía Instalar Ubuntu comenzaba el proceso de carga del instalador pero la pantalla se quedaba sin señal, lo mismo sucedía si en lugar de elegir Instalar yo seleccionaba la opción de Probar Ubuntu sin instalar.

Debido a esto opte por conectar un monitor externo para realizar la instalación, esto con la ilusión de que durante la instalación se instalarán los drivers correspondientes para que se vea la pantalla de la laptop, pero no resulto. Ahora ya tengo los dos sistemas operativos instalados y al arrancar la laptop aparece el menú donde yo puedo elegir el SO a iniciar, si selecciono Windows 8.1 todo funciona OK, pero si selecciono Ubuntu 13.10 aparece la primer pantalla naranja pero a los pocos segundos se queda sin señal.

La targeta gráfica del equipo es una Intel HD Graphics 4000 y en esta página de Intel: https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=13815 me indican que vaya a esta pagina para descargar los drivers correspondientes: https://01.org/linuxgraphics/downloads. Ya realice la instalación pero no me ha funcionado.

Un amigo me comento que cuando esto sucede debo editar manualmente un archivo de configuración en el que se establece la resolución de pantalla pero no se que archivo es ni como editarlo.

A algúno de ustedes conoce como solucionarlo?
Gracias por su atención.
 

Kbite

Aprender y compartir
Administrador
#2
Hola javier0730.

si selecciono Ubuntu 13.10 aparece la primer pantalla naranja pero a los pocos segundos se queda sin señal
Aunque no lo veas el GRUB sí está ahí, pero no lo ves porque tu monitor no puede autoajustar la resolución. Cuando te aparezca el aviso de que no dispones de señal pulsa la tecla Intro, espera un poquito y si todo ha ido bien ya estarás en Ubuntu.

Ahora tendrás que ajustar la resolución del menú de boteo abriendo un Terminal y ejecuta lo siguiente para editar el archivo GRUB:

Insertar CODE, HTML o PHP:
sudo nano /etc/default/grub
En el editor busca estas líneas:

Insertar CODE, HTML o PHP:
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# GRUB_GFXMODE=640x480
Ahora debes activar el GRUB_GFXMODE quitando el símbolo almohadilla (#) a la cuarta línea para que queda así:

Insertar CODE, HTML o PHP:
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=640x480
Guarda los cambios con Ctrl + o y vuelve al terminal para ejecutar el comando e incorporar las modificaciones al GRUB:

Insertar CODE, HTML o PHP:
sudo update-grub2
A continuación reinicias a ver si se ha solucionado, estoy ya algo oxidado con Linux pero espero te sirva.

Saludos, Kbite
 

javier0730

Miembro
Miembro
#3
Gracias por la rápida respuesta.

La pantalla se queda sin señal hasta después del GRUB, es decir que el menú si se ve bien y con una resolución de pantalla grande. Y si me deja elegir el sistema a iniciar, sólo hasta que selecciono Ubuntu es cuando la pantalla se apaga pero el sistema si se esta iniciando ya que al conectar un monitor externo puedo trabajarlo normalmente, sólo que sin el monitor de la laptop.
De todos modos hice lo que recomiendas y veo que la resolución de pantalla del GRUB si cambia y muestra una resolución de 640 x 480. pero al seleccionar el sistema se queda sin señal nuevamente.

Si conoces de otra cosa que pueda intentar, lo agradecería mucho.
 

Kbite

Aprender y compartir
Administrador
#4
Hola javier0730.

Desde luego es un problema de resolución de pantalla pero no conozco más pasos para indicarte, tan solo que deberías probar la última versión de Ubuntu 14.04.1 LTS que tal vez haya corregido el bug que te está dando la lata.

También buscar más información en Google, que hay mucha, sobre este tema ya que en mis notas, algo antiguas ya, no tengo nada nuevo que aportarte. De encontrar la solución te agradecería que la dejases en el foro para futuras consultas.

Saludos, Kbite
 

javier0730

Miembro
Miembro
#5
Buenas tardes.

Gracias nuevamente por el consejo Kbite, he actualizado a la versión 14.04 pero no se soluciono el problema.
Después de buscar e intentar varias cosas decidí intentar con la versión de Ubuntu 10.04 LTS y con esta funciono correctamente, así que el problema esta resuelto.

Desde mi opinión creo que la versión 10.04 es la más estable de todas las distribuciones de Ubuntu ya que en otras ocasiones he tenido diferentes tipos de problemas con versiones posteriores, los cuales nunca me han ocurrido en la versión 10.04.

Otro dato que les comparto es que intente con varias distribuciones de linux y el problema de la pantalla ocurrió en las siguientes versiones:
Ubuntu 13.10 (no da señal ni en modo live ni instalado)
Ubuntu 14.04 (no da señal ni en modo live ni instalado)
openSUSE 12.2 (no da señal en modo live, así que no lo instale ya que supongo que el problema continuaría)
opnenSUSE 13.1 (no da señal en en modo live, así que no lo instale)
Mint 16 (instalado no da señal pero en modo live funciona bien)
Fedora 14 (funciona bien en modo live)
Fedora 20 (no da señal en modo live, así que no lo instale)

Ubuntu 10.04 (funciona en modo live y también instalado) así que con esta me quedo.

Saludos.
 

Kbite

Aprender y compartir
Administrador
#6
Hola javier0730.

Pues gracias por la buena información que nos dejas. Es curioso que una distro ya antigua no tenga ese bug que tan comentado es en la red.

En este caso cero que podemos dar el tema como solucionado y lo cerraremos, esperemos que futuras distros solucionen el problema de la resolución de pantalla.

Saludos,. Kbite
 
Estado
Cerrado para nuevas respuestas
Arriba Pie