problemas con Directx 9.0B

Estado
Cerrado para nuevas respuestas

jabries

Nuevo Miembro
Miembro
#1
Ante todo, al ser la primera vez que escribo aquí saludo a todos.

Tengo un Nvidia Geforce 4 MX440 con los últimos drivers y he actualizado las Directx a la 9.0B, pues al usar la Herramienta de diagnsotico de DirectX, al hacer el Test DirectDraw cuando sale el cuadrado blanco rebotando a apntalla completa se queda pillao el ordenador, ¿culpa de los DirectX, de los drivers de Nvidia, de que? :(
 

dk01

Ex-Admin
Miembro
#2
Hola Jabries.

Debería andar bien en el ambiente que describes. Trata instalando el DirectX 9.0c.

Luego si sigue sin funcionar prueba reinstalando los drivers de la placa. También te recomiendo que pruebes si funciona el Direct3D de la placa. Si luego de reinstalar todo sigue sin funcionar, pídele una placa Nvidia prestada a algún conocido y prueba que esa tampoco funcione, ya que cabe la posibilidad que a la tuya se le haya dañado el micro (cosa que se por experiencia).

Buena suerte.
 

jabries

Nuevo Miembro
Miembro
#3
Mi maquína es un AMD Athlon 1GHz, 512 Mb RAM, 80 GB disco duro, Geforce4 MX 440, Maxi Studio ISIS, placa base Epox 8KTA+ con chipset VIA KT133, pos no probe lo que me dijisteis, pero probe otra cosa, probe Directsound,pos que sorpresa, pantallazo azul, "mmtask provoco un error en KRNL386.EXE" y ha reiniciar, probe por segunda vez el directsound y ya no me solto el pantallazo azul, me salio la ventanita pequeña con el mismo rollo que en el pantallazo azul, y sonaba música y to, pero daba error solo cuando recurria a buffer de software, cuando recurria a buffer por hardware no soltaba ningún mensaje de error . Despuésprobe lo que me dijiste, el direct3d, rayas a colores en la parte inferior de la pantalla y colgao completamente, a todo esto, con los DirectX 9.0C ya instalado, en principio no parece que sea de la tarjeta de video, no? ya no se que hacer, reinstalar windows? probare cambiando la tarjeta de video? no se por donde pillar el problema. :(
 

dk01

Ex-Admin
Miembro
#4
Hola jabries.

Por lo que me comentas parece ser que es indefectiblemente un problema del DirectX. Puedes probar reistalando Windows y volviendo a instalar el DirectX a ver si mejora un poco. Igualmente, previo a formatear tu disco, prueba otra placa de vídeo (por si las moscas, aunque le pongo mis fichas al problema del DirectX)

Saludos
 

jabries

Nuevo Miembro
Miembro
#5
Una preguntilla, ¿puede afectar una mala configuración en la BIOS?, este problema ya lo tuve antes, pero no le preste mucha atencion, en 2 formateos que hice me paso lo mismo, al hacer el test de directdraw se colgaba, lo del sonido solo lo probe esta vez, si esta fastidiada la tarjeta de video, ¿ puede afectar el resto?, probare lo que me comentas.
 

dk01

Ex-Admin
Miembro
#6
Hola Jabries.

Si, puede afectar una mala configuración del bios, pero sería bastante extraño que cause problemas tanto en el vídeo como en el sonido (a menos por supuesto que tengas mal configurado el slot AGP y que tu sonido sea onboard y que también esté mal configurado - como te imaginarás, es bastante rebuscado).

Yo particularmente me inclinaría por un problema de los controladores DirectX que se encuentren dañados. También puedes probar eliminando y volviendo a instalar los drivers de las placas de vídeo y de sonido, pero no creo que se deba a eso el error.

Lo de la placa de vídeo puede ser que esté dañada y esté causando problemas (sobre todo si tu sonido es on board aunque se da en muuuuuuuuuuy pocos casos), aunque por lo que me comentas tengo mis serias dudas. Yo, como ya dije, me inclino por un problema de los archivos del DirectX. Así que ya sabes, por las dudas prueba otra placa de antemano (pura y exclusivamente que para eliminar la posibilidad - no sea cosa que tengas que formatear y al fin de cuentas siga todo igual).

Ahora, también se me ocurre que puede ser algún conflicto relacionado con la ubicación de las placas. Si tu placa de sonido no es on board, cámbiala de slot y prueba nuevamente, no sea cosa que sea un conflicto de recursos (este caso se daba muy seguido sobre todo en las placas Soyo 5EH5).

Buena suerte.

P.D. Ahora también le mandaré un PM a Techy (la otra moderadora de este foro) para pedirle que le eche un vistazo a este post.
 

jabries

Nuevo Miembro
Miembro
#7
Te comento la historia, llevaba años sin ningún problema, ni de reinstalar, ni formatear ni nada, hasta hace un mes o así que haciendo experimentos con linux me daban errores en la particion (me decía algo de que no se correespondian las posiciones de inicio de las particiones con la posicion fisica de los clusters o algo asi, es decir que una particion me decía que estaba fuera del disco) de Windows por lo que decidi formatear, reinstale todo con bastantes problemas, y fue cuando por primera vez me salio el problema, no tengo ni la tarjeta de vídeo ni la de sonido onboard, no hay conflictos de IRQ´s ya que a las tarjetas no le toco desde hace bueno y me funcionaban perfectamente. Tambien se me paso por la cabeza que seria culpa del disco duro por el error que comente antes, pero eso (creo) que lo tengo solucionado.

Gracias por atenderme
 

Techy

Nuevo Miembro
Miembro
#8
uyyy que problema, :(

En primera cuando has echo el test no te has fijado en las demas opciones si tienes algún archivo fallando o algún problema ahi? no te indica si le falta o le sobra algo?, a ver si me explico mejor:

1. Ve a Inicio/ Ejecutar/ escribiendo "dxdiag", te saldra una ventana grande, creo que me entiendes, hay varias pestañas dentro de ellas una dice "Archivos de Dirext" pues fijate y ve si no hay problemas ahi, si es que algún archivo esta corrupto mal instalado o etc. es que parece que tu erro es por dirext :confused: lo mismo haces con controladores.

2. Ahora solo se te queda la maquína así cuando le das al Test de DirectDrwa o también al del Direct3D ?.

3. Estas tratando de usar algún juego, o ver algúna pelicula y te sale algún error gráfico?.

4. Has probado activar o desactivar la opción de el fast write (esto se hace desde la Bios)

5. Dices que tu problema empezó desde que experimentabas con Linux; en linux no tienes ningún problema?, y también comentame si sigues utilizando Linux.

6. Cuanto de Memoria tiene tu Tarjeta de Video? y estas seguro que las direcxt que ha instalado son compatibles con tu tarjeta? " http://www.nvidia.com/page/home "

Sorry si no te doy una respuesta exacta sino que para este tipo de problemas tenemos que conocer detalles de tu pc. Ten en cuenta que nosotros no etamos frente a tu PC y pues en muchos casos tenemos que imaginar los detalles ;)

Saludos y espero tus respuestas :rolleyes:
 

jabries

Nuevo Miembro
Miembro
#9
Haber, voy a intentar explicarlo lo mejor posible, esta claro que lo mejor que, como dices tu, no estas delante de mi ordenador para ver lo que le pasa.

1.- se a la que te refieres, me parece que es la primera, todo correcto.

2.-Con los dos,y con directmusic no se llega a pillar de todo,perosuelta errores.

3.-Con el need for speed no puedo cambiar de resolucion, se me queda. Las pelis la veocon el Powerdvd y se queda pillao al darle al stop o intentar cerrarlo.

4.-Si, continua haciendo lo mismo.

5.-Pues resulta que el linux lo tengo en un disco duro distinto, de esclavo, pero la swap la tenia en el master, se me casco el disco de linux (se me solto un conector de la corriente) hice varios intentos para que me viera la bios el disco y na, no me detectaba ninguno de los dos,ni siquiera en otro pc, al final,no se como,logre que me detectara el master, el de windows, ya tenia intenciones de formatearlo y así lo hice, volví a instalar el windows, acabada la instalacion, actualizado el Windows e instalado casi todos los programas que necesito le hice el dxdiag y fallo, no le di mucha importancia hasta que se me dio por instalar algún juego (need for speed, simcity 3000) me soltaban al ejecutar que faltaba un archivo requerido,el d3d8.dll? (me parece que era asi) hasta que me canse por no poder solucionar e intente pasar datos para salvar de una particion a otra ( tengo dos particiones en el disco duro) y haciendo esto se paro diciendo que "imposible copiar, archivo en uso" le doy a aceptar y colgao, solo se movia el puntero del raton haciendo un ruido como si rascara, botonazo, reinicio y sorpresa. NO SE ENCUENTRA SISTEMA OPERATIVO. Disco de inicio, formateo y vuelta a empezar hasta que volvieron a empezar los problemas y recurri a este foro pa ver si me podias echar una manita.

Mientras escribo esto he vuelto a formatear y estoy instalando Windows otra vez y me estoy dando cuenta que no detecta ningún dispositivo de los que tengo, pone todos por defecto, estoy intentandoinstalr los drivers de la tarjeta de vídeo y me dice que no se encontro el dispositivo, que lo instale primero, esto me huele mu mal, ¿placa base fastidiada?

6.- 64Mb, digo yo que si, Geforce4 MX 440.

Muchas, pero muchas gracias por vuestra atencion
 

jabries

Nuevo Miembro
Miembro
#10
he tomado otra direccion, estoy instalando todo paso a paso, he actualizado de win98 a millenium y ya me reconocio dispositivos, he instalado los drivers de la tarjeta de vídeo y he actualizado con Windows update solo el directx 9.0b y por ahora va, ire actualizando paso a paso a ver si puede ser de algúna actualizacion de seguridad lo que peta todo, seguire imformando.
 

jabries

Nuevo Miembro
Miembro
#11
Por fin, ya he encontrado el problema, ni placa base, ni directx,ni tarjeta de video, el problema, un programita que sirve pa enfriar la cpu, Vcool, ya nos podiamos volver locos, pos ya ta, solucionado, muchas gracias por ayudarme
 

Techy

Nuevo Miembro
Miembro
#12
Es que ya parecia demasiado extraño si que un error de Dirext te genere tantos problemas, perdona pero hoy recien he vuelto a ver tu post. y entrar al for, y me da mucho gusto que hayas solucionado tu problema, a veces estas cositas se encuewntran donde uno menos se lo imagina. Y lo que sigue pareciendo extraño es, tu decias que formateabas y te seguia saliendo el problema, osea, que tu formateabas y volvias a instalar el software :confused: pero te hubieras fijado cuando no lo tenias instalado.... bueno son cosas que pasan. lamentamos (dk01 y yo)no haberte podido ayudar como hubieramos kerido. :oops:

un Saludo!! :rolleyes:
 

jabries

Nuevo Miembro
Miembro
#13
Mi pc no puede pasar sin un programita de esos que enfria la cpu porque se pasa el dia encendido, segui haciendo pruebas y seguia fallando, aun desinstalando el programilla, y probe varios y todos me originaban el mismo fallo, así que habra que probar otra cosa, actualice a Windows XP a costa de perder la tarjeta de sonido (como supongo que sabeis los "listos" de guillemot no desarrollaron drivers de ISIS para XP) y haber que pasa, ya os contare.
 

gallito2005

Nuevo Miembro
Miembro
#15
al = que javier a mi me sale el eror que dice[

DDHELP provocó un error de página no válida en el

módulo <desconocido> de 0000:baabb208.

Registros:

EAX=002a001d CS=016f EIP=baabb208 EFLGS=00010202

EBX=00000010 SS=0177 ESP=007dfd38 EBP=007dfd4c

ECX=e485af90 DS=0177 ESI=00008dc2 FS=2c6f

EDX=00008dde ES=0177 EDI=007dfd54 GS=2e3f

Bytes en CS:EIP:

Volcado de pila:

,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x ,08x

esto ocurre cada ves que juego gunbound, pasan unos minutos y se cierra el juego

la verdad nos e que sera dirext, sonido, no se que mas. se que es un archivo de dirext.

es w98se actulizado todo, tal vez sera este el problema como dice javiers debe haber algúna actulizacion de microsoft que hace que falle el directx 9.0

 
I

ivaj

Guest
#17
tengo un problema similar en los juegos que no requieren directx (como age of mitology) no tengo problemas con los graficos, pero cuando corro juegos y aplicaciones que utilizan el directx 9 (editor de vídeo camtasia, ned for speed underground), me provoca un error de volcado de memoria y el cpu se apaga, no creo que sea un problema con la tarjeta de vídeo porque he probado con otra que si funciona en otra computadora, tampoco creo que sea problema de Windows o los controladores porque en otra pc si funciona perfectamente con la misma configuracion, el mismo Windows el mismo directx, al parecer podría ser un problema con la tarjeta madre o el bios alguien me puede orientar como puedo localizar el problema o si tienen algún tip para corregirlos se los agradecere infinitamente, SALUDOS A TODOS.
 
V

vergi

Guest
#18
Hola jabries.

Por lo que me comentas parece ser que es indefectiblemente un problema del DirectX. Puedes probar reistalando Windows y volviendo a instalar el DirectX a ver si mejora un poco. Igualmente, previo a formatear tu disco, prueba otra placa de vídeo (por si las moscas, aunque le pongo mis fichas al problema del DirectX)

Saludos
hola...

tengo un problema, no puedo ejecutar dxdiag empieza a cargar y no aparece el cuadro de dxdiag, en cambio cuando ejecuto regedit msconfig winipcfg si me funcionan......¿que hago?

saludos
 

ponticcelli

Nuevo Miembro
Miembro
#19
necesito ayuda cuando inicie mi ordenador me salio un mensaje :

MEMORIA INSUFICIENTE PARA EJECUTAR KRNL386.EXE, O BIEN LA ENTRADA WINDOWMENSIZE EN EL ARCHIVO SYSTEM.INI ES DEMASIADO GRANDE.

EJECUTE EL PROGRAMA DE INSTALACION

por favor cualquier ayuda lo agradecere,
 
Estado
Cerrado para nuevas respuestas
Arriba Pie